Back
Maintenance

Systems Maintenance

Completed 16 Jun at 06:00pm UTC.

Document Service Core API
Completed

Maintenance completed

Posted 16 Jun at 06:00pm UTC.
Started

We will update our software and services to enhance your O&D experience on Sunday, June 16, 2024, at 12:00 PM UTC. The maintenance window is 6 hours, with expected downtime of up to 3 hours. Our technical team will upgrade the systems to ensure service integrity. No action is needed from you, but please note that access to our services will be temporarily unavailable during this period.

Posted 16 Jun at 12:00pm UTC.